升级与编译自己的内核-Debian篇学习

首先要介绍一下,通常其它操作系统的内核编译是比较繁琐的。然而,由于Debian强大的dpkg软件包管理系统,使得内核的升级、编译也变得容易很多。这篇文章将会一步一步教你如何编译自己的,带有grsecurity的Linux 2.6内核。Grsecurity是一个Linux的内核补丁,针对Linux内核的某些安全漏洞进行修补以及安全性的增强。
首先用 apg-get 自动下载并安装一些必要的软件包,包括编译内核需要的kernel-package和ncurses-dev等。如果在内核编译、制作过程中,遇到错误提示说某个软件包不存在的话,请同样使用 apt-get install 命令进行下载安装。

apt-get install kernel-package ncurses-dev fakeroot wget bzip2 make patch

cd /usr/src
wget http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.7.tar.bz2
tar -xjf linux-2.611.7.tar.bz2

请到 http://www.kernel.org 查看最新的内核版本。

之后,下载grsecurity。请注意,务必选择与内核版本相应的grsecurity版本。(grsecurity网站)

wget http://www.grsecurity.org/grsecurity-2.1.5-2.6.11.7-200504111924.patch.gz

gunzip grsecurity-2.1.5-2.6.11.7-200504111924.patch.gz

执行以下命令将新内核打上grsecurity补丁

patch -p0 < ./grsecurity-2.1.5-2.6.11.7-200504111924.patch OK,切换到新内核的目录 cd linux-2.6.11.7 为了节省时间,请执行以下命令从现有内核中获得配置 make oldconfig

执行完此条命令后,会根据新老内核的

发表评论

电子邮件地址不会被公开。 必填项已用*标注